Welcome, Guest. Please login or register.
Did you miss your activation email?
October 01, 2014, 10:21:47 PM
Home Help Login Register      
News: NEW Follow LiveATC updates on Twitter and Facebook


+  LiveATC Discussion Forums
|-+  Air Traffic Monitoring
| |-+  Aviation Audio Clips (Moderators: dave, RonR)
| | |-+  Audio choppy. Scanner issue, antenna, or software issue?
« previous next »
Pages: [1] Go Down Print
Author Topic: Audio choppy. Scanner issue, antenna, or software issue?  (Read 3377 times)
Chadan
Full Member
***
Offline Offline

Posts: 116


WWW
« on: October 03, 2012, 08:45:04 PM »

The audio feed for my station sounds really poor. This coincided with moving my scanner, repositioning the antenna, and upgrading the operating system from 10.04 to 12.04 so I'm not sure what might have caused it. It doesn't happen all the time, but sure happens a lot. File attached.
Logged

Feed provider for KBNW out of Boone, Iowa on 123.0. Also catching chatter from nearby airports: KAMW (122.7), KIKV (122.9) and the Aviation Guard channel (121.5)
InterpreDemon
Sr. Member
****
Offline Offline

Posts: 420



« Reply #1 on: October 03, 2012, 10:38:33 PM »

Sounds like you either repositioned the antenna to an inferior location or accidentally turned the squelch up. The chopping definitely sounds like squelch action to me. Easy way to rule out feed interruption would be to just open the squelch up for a half hour and see what the archive sounds like... if no chop in the noise level or the voice transmissions you can assume it is your squelch setting and not the computer or feed. Alternatively you could just unplug the audio cable from the scanner and listen to the built-in speaker.
Logged

Feed Purveyor:
KJFK ARINC
KHPN ATIS
(KJFK) NY DEP Liberty East
HF CAR-A  3455/5550/6577/8846/11396
HF ARINC LDOC  6640/8933
HF NY VOLMET  6604

Complaints should be addressed to: City Hall
Chadan
Full Member
***
Offline Offline

Posts: 116


WWW
« Reply #2 on: October 03, 2012, 10:58:27 PM »

Thanks Demon! I didn't think of messing with the squelch since it's a digital tuner, but by opening it all the way up, and then pulling the audio cable out and listening to the scanner I have verified that the choppiness is caused after the scanner. It sounds just fine when listening through the built-in speaker.

So the question evolves - what in a software update would cause the audio to do that?
Logged

Feed provider for KBNW out of Boone, Iowa on 123.0. Also catching chatter from nearby airports: KAMW (122.7), KIKV (122.9) and the Aviation Guard channel (121.5)
denverpilot
Newbie
*
Offline Offline

Posts: 27


« Reply #3 on: October 04, 2012, 12:52:28 AM »

So the question evolves - what in a software update would cause the audio to do that?

Nothing. You didn't upgrade the software in the scanner. Wink

What else has changed in the environment?  Any new electronics nearby the scanner or antenna that might be emitting RF noise?
Logged
InterpreDemon
Sr. Member
****
Offline Offline

Posts: 420



« Reply #4 on: October 04, 2012, 11:37:31 AM »

Well, now that you have ruled out the radio the next thing I would be looking at is the sound card settings and performance settings in your hardware... but I am also wondering if there is some type of buffering issue with the stream itself that could manifest this way. In other words a network issue. The very best person to chime in on this would be Dave because whatever it is he has seen it all before. One thing you could do immediately is go to speedtest.net and see what your upload speed is.
Logged

Feed Purveyor:
KJFK ARINC
KHPN ATIS
(KJFK) NY DEP Liberty East
HF CAR-A  3455/5550/6577/8846/11396
HF ARINC LDOC  6640/8933
HF NY VOLMET  6604

Complaints should be addressed to: City Hall
Chadan
Full Member
***
Offline Offline

Posts: 116


WWW
« Reply #5 on: October 04, 2012, 01:01:51 PM »

Well, now that you have ruled out the radio the next thing I would be looking at is the sound card settings and performance settings in your hardware... but I am also wondering if there is some type of buffering issue with the stream itself that could manifest this way. In other words a network issue. The very best person to chime in on this would be Dave because whatever it is he has seen it all before. One thing you could do immediately is go to speedtest.net and see what your upload speed is.

I can hear the choppiness through the external speaker that is plugged into the server, so I can confirm that the problem happens somewhere between the audio-in jack and DarkIce.
Logged

Feed provider for KBNW out of Boone, Iowa on 123.0. Also catching chatter from nearby airports: KAMW (122.7), KIKV (122.9) and the Aviation Guard channel (121.5)
InterpreDemon
Sr. Member
****
Offline Offline

Posts: 420



« Reply #6 on: October 04, 2012, 01:52:11 PM »

I deduce that you upgraded UBUNTU from 10.4 to 12.4, and quick forum research found this is a known problem with that upgrade:

http://ubuntuforums.org/showthread.php?t=1979191

The solution for the guy who started that thread was:

added this line at the end of /etc/modprobe.d/alsa-base.conf:

options snd-hda-intel model=generic

This guy also solved his problem, perhaps similar to yours:

http://ubuntutechnical.wordpress.com/2012/05/21/sound-problems-after-ubuntu-12-04-upgrade/

And here's another one, including a Youtube link:

For me it dissapeared disabling automute
alsamixer => disable auto mute

Found the solution in this video:
Logged

Feed Purveyor:
KJFK ARINC
KHPN ATIS
(KJFK) NY DEP Liberty East
HF CAR-A  3455/5550/6577/8846/11396
HF ARINC LDOC  6640/8933
HF NY VOLMET  6604

Complaints should be addressed to: City Hall
Chadan
Full Member
***
Offline Offline

Posts: 116


WWW
« Reply #7 on: October 04, 2012, 02:38:15 PM »

Wow! Thanks for all your help demon! I'm sure I can resolve this the next time I am able to work on it!
Logged

Feed provider for KBNW out of Boone, Iowa on 123.0. Also catching chatter from nearby airports: KAMW (122.7), KIKV (122.9) and the Aviation Guard channel (121.5)
Chadan
Full Member
***
Offline Offline

Posts: 116


WWW
« Reply #8 on: October 04, 2012, 09:26:53 PM »

Tried adding the tip in Ubunuforums and no joy. Also looked for an 'automute' feature in ALSA but don't see it. I'll keep looking around since this seems to be a known problem. Thanks again!
Logged

Feed provider for KBNW out of Boone, Iowa on 123.0. Also catching chatter from nearby airports: KAMW (122.7), KIKV (122.9) and the Aviation Guard channel (121.5)
InterpreDemon
Sr. Member
****
Offline Offline

Posts: 420



« Reply #9 on: October 04, 2012, 10:52:03 PM »

Don't forget to email Dave, 'cause he's a real Linux geek and it's almost impossible he doesn't know the answer right off the bat.
Logged

Feed Purveyor:
KJFK ARINC
KHPN ATIS
(KJFK) NY DEP Liberty East
HF CAR-A  3455/5550/6577/8846/11396
HF ARINC LDOC  6640/8933
HF NY VOLMET  6604

Complaints should be addressed to: City Hall
Chadan
Full Member
***
Offline Offline

Posts: 116


WWW
« Reply #10 on: October 25, 2012, 09:30:33 PM »

Thanks for the help guys. I'm a little chagrin to say that the reason the audio was choppy is because the USB power to the scanner was cutting out each time the scanner locked onto an audio signal. I don't usually have a line-of-site to my scanner's LCD screen so I didn't realize it for about a month. However now that I plugged in an external (wall-wart) power supply the feed sounds fine! So I'm not sure if anything I did within Ubuntu 12.04 was necessary at all. Gotta love that  undecided
Logged

Feed provider for KBNW out of Boone, Iowa on 123.0. Also catching chatter from nearby airports: KAMW (122.7), KIKV (122.9) and the Aviation Guard channel (121.5)
Pages: [1] Go Up Print 
« previous next »
Jump to:  


Login with username, password and session length

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2011, Simple Machines Valid XHTML 1.0! Valid CSS!